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Prior to use, read these assembly instructions carefully and familiarize yourself with the product. 
Installation and start-up should not be carried out before reading and understanding this 
document. Keep these assembly instructions readily available so that you can reference them as 
needed. 
 

1.1  What Is the Purpose of this Assembly Instructions? 
These assembly instructions serve as an aid for the installation and operation of the product and 
support the technical staff with all operating and maintenance tasks to be performed. 
Furthermore, these instructions are aimed at preventing dangers to life and health of the user and 
third parties. 
 

1.2  Who Are these Assembly Instructions Targeted To? 
These assembly instructions provide a code of conduct for personnel tasked with the setup, 
operation, maintenance, and repair of gas engines. A certain level of technical knowledge with 
respect to the operation of gas engines and basic knowledge of the electronic components used 
are necessary. Persons who are only authorized to operate the gas engine shall be trained by the 
operating company and shall be expressly instructed concerning potential hazards. 
 

1.3  What Symbols Are Used in the Assembly Instructions? 
The following symbols are used in these instructions and must be observed: 

 

Example 

This symbol indicates examples, which point out necessary handling 
steps and techniques. In addition, you receive additional information from 
the examples, which will increase your knowledge. 

   

 

Notice 

This symbol indicates important notices for the user. Follow these. In 
addition, this symbol is used for overviews that give you a summary of the 
necessary work steps. 

   

 

Warning 

This symbol indicates warnings for possible risks of property damage or 
risks to health. Read these warning notices carefully and take the 
mentioned precautionary measures. 

1 General Information 
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Danger 

This symbol indicates warnings for danger to life, especially due to high 
voltage. Read these warning notices carefully and take the mentioned 
precautionary measures. 

  
 

1.4  Which Abbreviations/Acronyms Are Used in the Assembly Instructions? 
The following abbreviations/acronyms are used in the assembly instructions. 

Abb. Term Description Explanation 

AC Alternating Current Alternating current   

CAN bus Controller Area 
Network bus 

Bus for control 
devices/networks 

Asynchronous serial connection 
system for linking control units 

CE Conformité 
Européenne 

Conformity with EU 
directives 

Mark based on EU legislation for 
certain products in conjunction 
with product safety 

DC Direct Current Direct current  

EMC Electromagnetic 
Compatibility  Compatibility of electrical or 

electronic equipment items with 
their surroundings 

ISO International 
Organization for 
Standardization 

International 
Organization for 
Standardization 

 

ITB-DC Integrated Throttle 
Body Direct Control 

Throttle body with 
integrated stepper 
motor and stepper 
motor driver 

 

MICT MOTORTECH 
Integrated 
Configuration Tool 

 Software for configuring 
MOTORTECH controllers 

PE Protective Earth Protective conductor  

USB Universal Serial Bus  Serial connection system to link a 
computer to external devices 
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2.1  General Safety Instructions 
MOTORTECH equipment is manufactured as state of the art and therefore safe and reliable to 
operate. Nevertheless, the equipment can cause risks or damage can occur if the following 
instructions are not complied with: 

– The gas engine must only be operated by trained and authorized personnel. 

– Observe all safety instructions of the system and all safety instructions of the system 
operator. 

– Operate the equipment only within the parameters specified in the technical data. 

– Use the equipment correctly and for its intended use only. 

– Never apply force. 

– For all work such as installation, conversion, adaptation, maintenance, and repair, all 
equipment must be disconnected from the mains and secured against unintentional 
reactivation. 

– Perform only such maintenance and repair work as is described in the assembly instructions, 
and follow the instructions given while working. 

– Only use spare parts supplied by MOTORTECH for the maintenance of the device. 

– Further work must only be performed by personnel authorized by MOTORTECH. Non-
compliance with the instructions will void any guarantee for the proper function of the 
equipment as well as the responsibility for the validity of the certifications. 

– Safety devices must not be dismounted or disabled. 

– Avoid all activities that can impair the function of the equipment. 

– Operate the equipment only while it is in proper condition. 

– Investigate all changes that occur during operation of the gas engine or electronic engine 
control. 

– Ensure compliance with all laws, directives, and regulations applicable to the operation of 
your system, including such not expressly stated herein. 

– If the system is not entirely tight and sealed, gas may escape and result in explosion hazard. 
The inhalation of gas can also lead to death or severe health damages. Therefore, upon 
completion of all assembly works, always check the system's tightness. 

– Always ensure adequate ventilation of the engine compartment. 

– Ensure a safe position at the gas engine. 

– There is a risk of burning on hot surfaces. Allow the gas engine to cool down before starting 
any work. 

– Personal protective equipment (PPE), e.g. safety shoes and gloves, must be worn during all 
work on the gas engine. 

– Noise from the system can cause permanent or temporary damage to your hearing. Wear 
suitable hearing protection at the system. 

– Your behavior can reduce possible residual risks to a minimum. Observe responsible handling 
of the gas engine and the gas-carrying system. 

 

2 Safety Instructions 
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2.2  Electrostatic Discharge Hazards 
Electronic equipment is sensitive to static electricity. To protect these components from damage 
caused by static electricity, special precautions must be taken to minimize or prevent 
electrostatic discharge. 

Observe these safety precautions while you work with the equipment or in its vicinity. 

– Before performing maintenance or repair work, ensure that the static electricity inherent to 
your body is discharged. 

– Do not wear clothing made from synthetic materials to prevent static electricity from building 
up. Your clothing should therefore be made of cotton or cotton mix materials. 

– Keep plastics such as vinyl and Styrofoam materials as far away from the equipment and the 
work environment as possible. 

– Do not remove the circuit boards from the housing of the device. 
 

2.3  Information on Electric Isolation 
If ground and earth potential are not properly isolated, the following problems as well as others 
can occur: 

– Electromagnetic interferences (e.g. ground loops) 

– Signal corruption (e.g. of the analog voltage signal) 

– Unwanted leakage currents 

Therefore, earth potential and the negative pole of the power supply of all devices in the electric 
assembly that provide the option, should be connected separately. If possible, the negative pole 
of the power supply should only be connected to earth potential at one point in the entire system. 

Wiring Example 
      Device with 

shielded wires 
Device featuring 
protection class II 
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Occurrence of ground loops 

The devices shown in the following image do not feature the possibility to 
connect the earth potential and the negative pole of the power supply 
separated from each other. This results in a ground loop. 

A ground loop is a ground connection of an electric wiring assembly that 
is closed as a loop. Due to impedance (resistance R > 0) of the loop, low-
frequency interference currents can lead to an unwanted voltage drop in 
the signal path. 

  Device 1 Device 2 

 
  Ground loop 

  

    
 

2.4  Special Safety Instructions for the Device 
  

 

Explosion hazard! 

If the system is not entirely tight and sealed, gas may escape and result in 
explosion hazard. Upon completion of all assembly works, always check 
the system's tightness. The formation of explosive gases in the area of 
the device must be prevented, e.g. by adequate ventilation or the use of 
gas sensors which switch off the gas supply. Also comply with all locally 
applicable explosion protection regulations. 

All works involving gas-carrying parts must be executed by trained 
personnel only. 
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Explosion hazard! 

Do not disconnect any connectors while the system is live. There is a risk 
of explosion. 

   

 

Risk of burning! 

High temperatures may occur on the surface of the system especially on 
the stepper motor. 

   

 

Risk of injury! 

The ITB-DC throttle body is designed for operation in circuits with 
protected extra-low voltage (PELV). The voltages in these circuits must 
not exceed 50 V AC or 75 V DC. 

The ITB-DC throttle must not be electrically connected to circuits which 
carry dangerously high voltages or which could do so if a single fault 
occurs. 

Therefore, the following conditions, among others, must be fulfilled: 

– The power supply may only be provided from power supply units with 
safe electrical isolation or from batteries. 

– The power supply line must be protected with a suitable fuse to 
protect the circuit from overload and short circuits. 

– Relays with safe isolation must be used for coupling to circuits that 
carry or in the event of a failure could carry dangerous voltage. 

– All currently applicable standards and regulations must be taken into 
account. 

   

 

Operational safety! 

All screws of the connectors must be adequately tightened. 
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Operational safety! 

The proper functioning of the device is only guaranteed if the device is 
operated within the permissible supply voltage range. Therefore, use a 
power supply according to the specifications in the assembly 
instructions. 

 

 

Operational safety! 

The throttle body can overheat and mechanical components including the 
ball bearing can block if the throttle body is coated with paint. To ensure 
proper operation, the throttle body must not be coated with paint. 

      

 

Danger of interference with radio reception! 

The device is not intended for use in residential areas and cannot ensure 
adequate protection of radio reception in such environments. 

     
 

2.5  Safety Concept 
To ensure safe operation, the gas engine must be equipped with an independent shut-off device 
that can be used to switch off the engine if the throttle fails. The throttle on its own is not a safety 
function. Depending on the interface used, there are also different ways of detecting an error so 
that an appropriate response can be made.  

Use of the Analog Current Input 
If the analog current input is used for control, the binary error output (Error) should be used to 
immediately detect an error, react and switch off the motor if necessary. 

The analog current input should also be monitored via the optional Cable Break Detection. Refer to 
the section Monitoring the Control System on page 43. 

Use of a Fieldbus (CAN) 
If a fieldbus is used for control, either the binary error output (Error) should be used or the error 
bits of the fieldbus protocol should be evaluated. 

In order to detect a fieldbus failure, Fieldbus Monitoring should be activated in the MICT. In 
addition, monitoring of the fieldbus communication by the master control system should be 
ensured. Refer to the section Monitoring the Control System on page 43. 
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2.6  Proper Disposal 
For the proper disposal of MOTORTECH equipment, observe the information provided at 
www.motortech.de. 
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3.1  Functional Description 
The ITB-DC throttle body controls the supply of the gas-/air mixture to the gas engine. The 
change in the opening angle of the throttle body is specified via the integrated stepper motor 
driver and implemented by the stepper motor. In this way, the speed and power of the motor are 
controlled in conjunction with the connected speed control. 

The control of the throttle can be manual or automatic. Manual settings are made via a connected 
computer. In automatic mode, binary or analog input signals, such as those provided by a master 
control, are analyzed. In addition, a connection via CAN bus  is possible. 

The throttle is configured using a connected computer. The software (MICT) used for this purpose 
is also used to display current system data and error messages. 

 
 

3.2  Applications 
  

 

Danger of interference with radio reception! 

The device is not intended for use in residential areas and cannot ensure 
adequate protection of radio reception in such environments. 

  
The ITB-DC throttle is suitable for use on stationary gas engines in continuous operation with a 
maximum ambient temperature of +85 °C (+185 °F). The temperature of the media flowing through 
must not exceed +80 °C (+176 °F). 

As per EN 55011, the ITB-DC throttle is equipment of Group 1 and Class A. 

Any use other than the one described in the assembly instructions shall be considered improper 
use and will result in the voiding of all warranties. 

3 Intended Use 
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System Overview (Example) 

 

 

 VariStep3 stepper motor driver  Engine 

 VariFuel3 gas mixer  Wiring rail (ignition) 

 ITB-DC throttle body  Gas supply 

 SC100 speed control  Gas train 

   Air supply 

   Air filter 

   Impulse line 
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4.1  Technical Data 

4.1.1 Certifications 

Machinery Directive 
– The ITB-DC throttle body is partly completed machinery according to article 2g of the EC 

Machinery Directive. 

– The partly completed machinery must not be put into service until the final machinery into 
which the product is to be incorporated has been declared in conformity with the provisions 
of the Machinery Directive. 

The ITB-DC throttle is certified as follows: CE 

The certificates are enclosed with your product. 
 

4.1.2 Mechanical Data 
The ITB-DC throttle body has the following mechanical characteristics: 

Feature Value 

Dimensions See section Overview Drawings on page 21 

Weight See following table 

Shape of device See section Overview Drawings on page 21 

Diameter of the throttle body See following table 

Maximum rotation angle of the 
throttle body 

80° 

Chemical resistance Water, oil, gaseous fuels 

Maximum absolute pressure 4.5 bar 

Maximum temperature of media 
flowing through 

+80 °C (+176 °F) 

Connection stepper motor  24-pole military style connector 

Permissible vibrations 5 Hz to 25 Hz: constant vibration displacement of 1.6 mm 
25 Hz to 100 Hz: constant acceleration of 4 g  
100 Hz to 1,000 Hz: constant acceleration of 2.8 g 

Climatic environmental conditions –40 °C to +85 °C (–40 °F to +185 °F) 

Max. 95 % humidity without condensation 
up to max. 4,000 m above sea level 
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Weight 
The weight depends on the type, series and diameter of the throttle. 

Series Diameter of the throttle body Weight 

50 series 42 mm (1.65") 2.4 kg (5.29 lbs) 

100 series 55 mm (2.17") 3.0 kg (6.61 lbs) 

  60 mm (2.36") 2.9 kg (6.40 lbs) 

  68 mm (2.68") 2.9 kg (6.40 lbs) 

140 series 75 mm (2.95") 4.0 kg (8.82 lbs) 

  80 mm (3.15") 3.9 kg (8.60 lbs) 

  85 mm (3.35") 3.8 kg (8.38 lbs) 

150 series 90 mm (3.54") 4.8 kg (10.58 lbs) 

  100 mm (3.94") 4.5 kg (9.92 lbs) 

152 series 100 mm (3.94") 4.0 kg (8.82 lbs)  

200 series 100 mm (3.94") 6.4 kg (14.11 lbs) 

  105 mm (4.13") 6.2 kg (13.67 lbs) 

  110 mm (4.33") 6.1 kg (13.45 lbs) 

  115 mm (4.53") 5.7 kg (12.57 lbs) 

  120 mm (4.72") 5.6 kg (12.35 lbs) 

  125 mm (4.92") 5.4 kg (11.91 lbs) 

 
 

4.1.3 Warning Notices on the Device 
  

 

Validity of warning notices on device 

The warning notices on the device are valid for the ITB-DC and all 
components connected to it. 

  

Warning Notice on the Device 
WARNING 
EXPLOSION HAZARD! 
Do not connect or disconnect when energized.  
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Warning Symbols on Device 
  

 

Warning of a hazardous point 

 

Warning of hot surface 

  
 

4.1.4 Product Identification – Labeling on the Device 
The necessary numbers for unique product identification are on the device: 

– Part number of the throttle body (P/N) 

– Arrangement number of the throttle (A/N) 

– Revision number of the throttle indicating its precise construction status (R/N) 

– Serial number of the throttle body (S/N) 

On the Throttle Body 

 

(Illustration example) 
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On the Connector 

 
 

4.1.5 Electrical Data 
The ITB-DC throttle body has the following electrical characteristics: 

Feature Value 

Power consumption Max. 72 W 

Power supply Nominal voltage: 24 V DC 
Operating voltage: 16.8 V DC to 32 V DC 

Required current Max. 4 A  

  

Electrical Data for Inputs and Outputs 
The inputs and outputs of the ITB-DC throttle have the following electrical data: 

Inputs and outputs Values/characteristics 

Binary input (Reset) – Galvanically separated 

– Input voltage up to 32 V DC 

– Input current at least 5 mA for high level 

– Save low level:  
Voltages below 1.0 V DC 

– Save high level:  
Voltages above 4.5 V DC 

When the reset signal is given, the high level must be present at 
the relevant input for at least 50 ms before it is possible to initiate 
the reset. 
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Inputs and outputs Values/characteristics 

Binary output (Error) – Galvanically separated 

– Switching voltage: max. 32 V 

– Current: max. 50 mA 

– Max. voltage drop at 50 mA: 1.9 V 

– NC or NO contact depending on the configuration in the MICT 
(see Inputs/Outputs – Control Setup on page 59) 

Analog current input Permissible current: 0 mA to 20 mA 

Max. difference in potential relative to ground: +3.5 V 

Input resistance: max. 25 Ω 

Analog current output Output current: 0 mA to 20 mA 

Working resistance: max. 500 Ω 

 
 

4.1.6 Interfaces 

USB Interface 
– Compatible with USB 2.0 

– Connector type B 

– Galvanically isolated 

CAN Bus Interface 
– Classic Extended Frame Format (CAN 2.0B) 

– As per ISO 11898, up to 1 Mbit/s 

– Transient-proof (automotive classification) 

– Max. 110 participants 

– Galvanically isolated 
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4.1.7 Overview Drawings 

50 series (P/N 30.51.050-D) 
P/N 30.51.055-D also corresponds to the following drawing, but without the gasket (O-ring 
56.75 mm x 3.53 mm [2.23" x 0.14"]) and the groove required for it. 
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100 series (P/N 30.51.100-D) 
P/N 30.51.105-D also corresponds to the following drawing, but without the gasket (O-ring 
82.14 mm x .,53 mm [3.23" x 0.14"]) and the groove required for it. 

 



4 Product Description 
 

Rev. 11/2025 23 

140 series (P/N 30.51.140-D) 
P/N 30.51.145-D also corresponds to the following drawing, but without the gasket (O-ring 
98.02 mm x 3.53 mm [3.86" x 0.14"]) and the groove required for it. 
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150 series (P/N 30.51.150-D) 
P/N 30.51.155-D also corresponds to the following drawing, but without the gasket (O-ring 116 mm 
x 3 mm [4.57" x 0.12"]) and the groove required for it. 
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152 series (P/N 30.51.152-D) 
The 152 series is only available with gasket (O-ring 116 mm x 3 mm [4.57" x 0.12"]). 
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200 series (P/N 30.51.200-D) 
P/N 30.51.205-D also corresponds to the following drawing, but without the gasket (O-ring 
148.82 mm x 3.53 mm [5.86" x 0.14"]) and the groove required for it. 
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4.1.8 USB Port and LED 
The USB port and the LED are located on the side of the housing of the controller. The USB port is 
locked with a screw. 

  

 

  Pos. Description 

   Locking screw of the USB port 

   LED for status signaling 

      

(Illustration example) 

Status Signaling 
The status of the ITB-DC throttle is signaled via the LED on the device. 

– Flashing green: Error-free operation 

– Flashing orange: Warning 
Warnings can be confirmed via MICT, fieldbus or the external reset signal. In addition, the LED 
flashes orange for the following reasons. 

– Invalid configuration data was detected. 

– Overtemperature or over current error confirmed by MICT. 

– A reference run is required. 

– Flashing red: Error 
Errors can be confirmed via MICT, fieldbus or the external reset signal. Errors can for example 
be caused by: 

– Step loss of the stepper motor e.g. due to overload 

– Overtemperature 

– Low voltage 

– Over current 

– Position target timeout (fieldbus) 

– Cable break (analog input) 

– Critical error/assertion 

– Alternate flashing of red and green: 
The supply voltage for the device was too low during start up. 
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4.1.9 Technical Data of the Stepper Motor 
The control results in the following technical data for the stepper motor: 

Feature 50, 100, 140, 152 series 150, 200 series 

Step width < 0.06° < 0.06° 

Speed (when open from 10 % 
to 90 %) 

35 ms 35 ms 

Holding torque 1.7 Nm (1.25 lb-ft) 5.4 Nm (3.98 lb-ft) 
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5.1  Unpacking 
Unpack the equipment, taking care not to damage it. Always place the device safely and protected 
from falling over or falling down. Ensure that the assembly instructions are always stored with the 
device and is easily accessible. Check the contents for completeness and verify that the device 
type meets your application requirements. 

Scope of Supply 
The scope of supply of the ITB-DC throttle body consists of the following components: 

– ITB-DC throttle body 

– Two O-rings, if necessary 

– Storage device with software for configuration of the throttle 

– Assembly instructions 

– USB interface cable for connecting the throttle to a computer 

– Declaration of Incorporation 

– EU Declaration of Conformity 

Required Accessories 
– Harness for connection between the throttle and master control resp. speed control. 
 

5.2  Mounting the Device 
       

 

Explosion hazard! 

If the system is not entirely tight and sealed, gas may escape and result in 
explosion hazard. Upon completion of all assembly works, always check 
the system's tightness. The formation of explosive gases in the area of 
the device must be prevented, e.g. by adequate ventilation or the use of 
gas sensors which switch off the gas supply. Also comply with all locally 
applicable explosion protection regulations. 

All works involving gas-carrying parts must be executed by trained 
personnel only. 

    

 

Risk of destruction! 

Make sure that the device is not covered and ensure sufficient circulation 
of air. 

    

5 Installation Instruction 
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Operational safety! 

To ensure sufficient cooling by the cooling body, do not paint and/or 
cover the ITB-DC throttle body. Also protect the cooling body from 
pollution. 

     

 

Consider the connector 

During planning of the installation, consider the dimensions of the 
connector on the harness (about 100 mm (3.94") on the 90° connector). 

     

When installing the throttle in the intake section, also observe the engine manufacturer's 
specifications and ensure safe handling. The installation location of the throttle body can be freely 
selected. 

1. For throttles with groove, insert the supplied O-rings on both sides of the throttle (see 
illustration). 



5 Installation Instruction 
 

Rev. 11/2025 31 

Example: 150 series 
 

 

For throttles without a groove, use gaskets that match your mounting flanges. 

2. For the installation of the throttle body between the two flanges, use four continuous screws 
or threaded rods (strength class 8.8 or higher). 
 Use the following torques:  

– M8: 25 Nm ± 10 % (18.4 lb-ft ± 10 %) 

– M10: 49 Nm ± 10 % (36.1 lb-ft ± 10 %) 

3. Check the system's tightness. 

4. Connect the harness with the connector to the stepper motor of the throttle, taking the 
following points into account: 

– Tighten the union nut to approx. 13 Nm (9.6 lb-ft). 

– Use medium strength thread lock fluid. 

5. To reduce vibrations at the connector, mechanically support the harness after a maximum of 
20 cm (7,87") if possible. 

6. When disconnected from the power supply, connect the open end of the harness to a master 
control or speed control. For this, read the operating manual on your respective control. 
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Risk of damage to the device! 

Incorrectly installed wiring can cause damage to the device. Please 
adhere to the following points: 

– Do not disconnect connectors under load. This can cause an arc. 

– Use the prescribed wire cross sections and suitable wire end 
ferrules. 

   

 

Wiring of components 

If you are not using harnesses manufactured by MOTORTECH, carry out 
the wiring according to the following specifications: 

– Power supply: 
2-wire cable, min. conductor cross-section 0.75 mm², max. cable 
length 10 m (32') 
If the cable length is longer, a respective larger cross-section must 
be selected (10 m to 30 m min. conductor cross-section 1.5 mm²) 

– Binary inputs and outputs: 
multicore cable, min. conductor cross-section 0.2 mm², max. cable 
length 30 m (98') 

– Analog inputs and outputs: 
multicore, shielded cable, min. conductor cross-section 0.2 mm², 
max. cable length 30 m (98') 

– CAN bus: 
shielded bus cable in compliance with ISO 11898-2 and CiA® 303-1, 
e.g. 2-pair, shielded bus cable, min. conductor cross-section 
0.34 mm², max. cable length 250 m (820') at 250 kbit/s 

     

6 Wiring of the Device 
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Grounding 
The device must be connected to the earth potential of the system via the provided earth 
connection (e.g. on the motor block). 

 

  

Pos. Designation 

 Circuit board 

 Housing 

 Negative pole L– of the voltage supply  

 Earth 

 Insulation 

  
– Earth 

Conductive connection with the earth (potential equalization, PE). The enclosure of the device 
has to be connected to earth. 

– Shield 
All shield connections are labeled Shield and are conductively connected to the enclosure of 
the device. 

– Negative pole L– of the power supply 
Reference potential of the electrical circuit on the circuit board inside the device. The 
negative pole L– of the power supply and the signal connection labeled GND are connected to 
the ground. The enclosure of the device is not or only capacitively connected to ground. 
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6.1  Connector on the Device 

The device is connected via the 24-pole military style connector. 

 

 

Pin Description Pin Description 

A Reset – N Position I in + 

B Reset + P Position I in – 

C CAN Shield Q Power In L – 

D Position I out GND R Not assigned  

E CAN ID 2 S Not assigned  

F CAN Com T Not assigned  

G CAN Low U Error – 

H Position I out + V Not assigned 

J Analog Shield W Not assigned  

K Error + X Not assigned  

L CAN ID 1 Y Not assigned  

M CAN High Z Power In L + 
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6.2  Wiring of Power Supply 
  

 

Risk of injury! 

The stepper motor may be started unintentionally when the supply 
voltage is applied. There is a risk of fingers or other body parts being 
trapped or squashed. Therefore, work on the connected devices (throttle 
body) must always be carried out with disconnected supply voltage. 

     

 

Throttle body grounding 

In order to comply with the EMC requirements and to dissipate 
electrostatic charges, it is absolutely necessary that the throttle body has 
a good conductive connection to the engine block and to earth. 

   

The use of the original MOTORTECH harness is recommended for wiring the power supply and 
connection to a master control. If you are using a different harness, please refer to the information 
box in the section Wiring of the Device on page 32.  

The power supply must be protected with an external fuse. When selecting the fuse, the maximum 
current for the cross-section of the selected wiring must be observed. 
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L ≙ 24 V DC (nominal voltage) 

 

  

Variations 

1 Battery Generator Control unit 

  

 

2   Power supply 

  

 

3   Battery Charger 
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6.3  Wiring Binary Inputs 
L ≙ 5 V DC to 32 V DC 

Wiring example (CAN ID 1 and CAN ID 2 in the connector bridged to the analog ground connection) 

  

Pin Designation Function 

B Reset + If a high level is applied for at least 50 ms, the throttle body is 
reset and the error mode is exited should an error exist. 
Subsequently, it initiates a reference run. The input can be 
switched both on the side of the operating voltage and on the 
ground side. 

A Reset – 

L CAN ID 1 These inputs can be used to define one of four CAN addresses for 
the device (Harness Coding), so that a master control can 
differential, between up to four throttles that are installed on 
different engine sides for example. The pins must be bridged 
directly in the connector to the analog ground connection (Pin D) 
and are not galvanically isolated. If a pin is bridged, this 
corresponds to a logical 1. The pins are only queried after 
switching on the throttle or after downloading a new 
configuration.  

E CAN ID 2 

  
The following table shows which coding corresponds to which instance. The assignment of the 
respective instance to the communication parameters in the fieldbus is carried out in the MICT 
(see Miscellaneous – Communication on page 62). 
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Instance (in MICT) CAN ID 1 CAN ID 2 

0 0 (open) 0 (open) 

1 1 (bridge) 0 (open) 

2 0 (open) 1 (bridge) 

3 1 (bridge) 1 (bridge) 

  
 

6.4  Wiring Binary Output 
L ≙ 5 V DC to 32 V DC; max. 50 mA 

The output can switch both ground and the operating voltage. 

 

Pin Designation Function 

K Error + The output can be configured as a normally closed or normally 
open contact via the MICT and switches if an error has occurred 
and the throttle is in automatic mode. To leave the error condition 
you need to acknowledge the error. This can be done via the 
binary input Reset, the MICT or via the fieldbus. 

U Error – 
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6.5  Wiring Analog Inputs and Outputs 
  
  Master control 

(e.g. speed controller) 

 

  

Output (position target) 

  

  

  

  

Input (position feedback) 

 

  

Pin   Designation Function 

N 

  A
n

al
o

g
 In

p
u

ts
 Position I in + Current input used to adjust the throttle body. The input has 

a value range from 0 mA to 20 mA and can be configured via 
the MICT, for example to 4 mA to 20 mA. 

 

 

P Position I in – 

J Analog Shield Shield 

D 

  A
n

al
o

g
 O

u
tp

u
ts

 Position I out GND Current output that exports the current position of the 
stepper motor as appropriate signal. The output has a value 
range from 0 mA to 20 mA and can be configured via the 
MICT, for example to 4 mA to 20 mA. 

 

 

H Position I out + 
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Example: Use of a voltage input 

The SC100 speed control has a voltage input. The following steps are 
required to connect the position feedback signal of the ITB-DC (current 
output) to the feedback input of the SC100 (voltage input): 

1. Connect the 270 Ω resistor supplied with the harness in parallel to the 
signal lines between the ACT fbd and Fdb GND clamps on the SC100.  

2. Define the values under Analog sensors in WinScope; e.g:  
Fdb 0 pos: 0.70 V 
Fdb 100 pos: 4.48 V. 

3. Adjust the values of the analog current output on the configuration 
page Inputs/Outputs – Control Setup in the MICT: e.g. 
Close: 2.6 mA (0.70 V/270 Ω = 2.6 mA) 
Open: 16.6 mA (4.48 V/270 Ω = 16.6 mA) 

  
 

6.6  Wiring CAN Bus 
    

 

CAN bus wiring 

Note the following when connecting the CAN bus: 

– Each bus end must be fitted with a terminating resistor of 120 Ω (see 
drawing). 

– Only use cables that are specified by the manufacturer for use in the 
CAN bus. 

– The shield must be connected across the entire bus cable. 

– The cable shielding must be connected to earth at one point. 

– The reference potential (Com) of the CAN bus must be connected to 
earth at exactly one point. 

– The maximum cable length depends on the bit rate: 

Bit rate Maximum cable 
length 

Maximum length 
of a stub 

Maximum length 
of all stubs 

1 Mbit/s 25 m (82') 1.5 m (5') 7.5 m (25') 

800 kbit/s 50 m (164') 2.5 m (8') 12.5 m (41') 

500 kbit/s 100 m (328') 5.5 m (18') 27.5 m (90') 

250 kbit/s 250 m (820') 11 m (36') 55 m (180') 

125 kbit/s 500 m (1,640') 22 m (72') 110 m (360') 

50 kbit/s 1,000 m (3,280') 55 m (180') 275 m (902') 

  

– Comply with the standards ISO 11898-1 and CiA® 303-1. 
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The terminating resistor may already be included in the harness. For this, please refer to the 
harness wiring diagram. The throttle should preferably be installed at one end of the bus. If this is 
not possible, the maximum permissible length of the stub must be taken into account. Please refer 
to the information in the box above. 

 

  First device Second-to-last device 

 

   Second device Last device 
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7.1  Manual and Automatic Operation 
The throttle opening can be adjusted in two operation modes: 

– Manual operation 

– Automatic operation 

You can switch between manual and automatic operation via the MICT. The selected operation 
mode is signaled in the window Runtime Data – Overview via status displays. Refer to the section 
Runtime Data – Overview on page 66. 

Manual Operation 
In manual operation, the external input signals of the master control are ignored. The position of 
the throttle can then be changed via the MICT(Device -> Manual Adjustment). The throttle must 
also be in manual operation to transfer a changed configuration to the device. 

  

 

Risk of destruction! 

In manual operation, the signals of the master control are not analyzed. If 
you make any adjustments in the manual mode with the gas engine 
running, make sure that these settings do not endanger the correct 
operation of the gas engine. 

  

Automatic Operation 
In automatic operation, the throttle body evaluates the external input signals of the controller 
connected. The device cannot be configured via the MICT. In automatic operation, the MICT can 
only be used to display the data and to create log files. 
 

7.2  Reference Run 
After the device is switched on or was reset, the ITB-DC throttle body initiates a reference run. 
This means that the closed position of the throttle is determined. In automatic mode, the stepper 
motor subsequently approaches the position defined by the master control. In manual operation, 
the throttle initially remains in the closed position. 

No signals are evaluated at the inputs during the reference run. A reference run can also be 
triggered via the MICT. In addition, the reference run is signaled in the window Runtime Data - 
Overview via a status display. Refer to the section Runtime Data – Overview on page 66. 
 

7.3  Open/Closed Positions 
The Open and the Close position are specified as follows: 

– Open: Throttle is completely open (100 % open) 

– Closed: Throttle is completely closed (0 % open) 

The throttle cannot be moved beyond these two positions and all corresponding signals are 
limited. 
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7.4  Configurable Opening Angles (Position 1 and 2) 
Two opening angles can be configured via the MICT, which can be controlled in manual mode via 
the MICT and in automatic mode via fieldbus. In this way, you can define the opening angles for 
certain operating states such as starting or purging the gas engine. 

You can configure positions 1 and 2 with the MICT. For further information, refer to the section 
Positions – Values on page 61. 
 

7.5  Changing the Opening Angle 
In automatic mode the opening angle can be controlled directly via the following inputs. 

– Analog current input 0-20 mA 

– Fieldbus CAN  

Depending on which master control you are using, you can select the required input using the 
MICT. If one of both end positions (open or closed) has been reached, the signals are limited at the 
inputs in the corresponding direction. 

You can configure the inputs with the MICT. Refer to the section Inputs/Outputs – Control Setup 
on page 59. 
 

7.6  Analysis of Positions via Analog Outputs or Fieldbus 
The current position of the throttle body can be sent to the master control via an analog voltage 
output or a fieldbus. The MICT can be used to configure which current value corresponds to the 
open or closed position. The current applied on the output is then set accordingly proportional to 
the current opening angle. 

You can configure the output with the MICT. Refer to the section Inputs/Outputs – Control Setup 
on page 59. 
 

7.7  Monitoring the Control System 
Depending on the control of the throttle, additional monitoring functions can be activated in the 
MICT:  

– Cable Break Detection 
If the throttle is controlled via the analog current input, Cable Break Detection can be 
activated in MICT (see Inputs/Outputs – Control Setup on page 59). A Failure Threshold can 
be defined for cable break detection. If the input current undercuts this failure threshold, the 
throttle enters the error state. 

– Fieldbus Monitoring 
If the throttle is controlled via fieldbus, Fieldbus Monitoring can be activated in MICT (see 
Inputs/Outputs – Control Setup on page 59). For the fieldbus monitoring a Position Target 
Timeout can be defined. If no position target is preset via the fieldbus for longer than this 
specified time, the throttle goes into the error state. 

In the error state, the binary error output (Error) is switched in both cases. If an error position is 
defined in the MICT, the throttle attempts to assume this position if this is still possible. For 
example, in the event of a step loss or overcurrent error, the stepper motor can generally no 
longer fulfill this request. For further information, refer to the section Positions – Values on 
page 61. 
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7.8  Access Control 
You can protect the ITB-DC throttle against unauthorized access by establishing the access 
control in the MICT. The access control has four operating levels, three of which can be secured 
with different PINs. As a default setting, the access control is not activated. If the access control 
for the throttle is activated, it is independent from the access levels that control authorizations 
within the MICT. 

  

 

Access Control 

A user is logged in to the Advanced Service access level on the MICT. He 
changes a configuration and would like to download the change to the 
throttle. Although he has the full authorization set in the MICT, he is 
prompted to log in with the PIN for the Level 3 (Master). This ensures that 
it is not possible for any user with an MICT and the generally valid 
password to change the configuration of your throttle. 

  
Various functions are at your disposal on the four operating levels. The figure below illustrates 
this: 

 

The following functions are available on the different levels: 

– Level 0 (Read Only) 
Enables read-only access for all users. 

– Level 1 (Operator) 
At this level the user can make position changes (closed and open position, position 1 and 
position 2, and make manual changes to the opening). Beyond that, he can change the 
operation mode and can confirm errors. 
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– Level 2 (Service) 
The service personnel can also initiate a reference run and reset the counter in the runtime 
data for the maximum number of step losses that occurred. 

– Level 3 (Master) 
At this level, the master can also reset all PINs and enable or disable the access control. 
Moreover, only the master is authorized to download a changed configuration to the throttle. 

For information on the access levels in the MICT, refer to the section Access Levels in the MICT 
on page 47. 
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MICT is an abbreviation for MOTORTECH Integrated Configuration Tool. You configure your ITB-
DC throttle via the MICT and can adapt it to the master control. 

If you are using a different version of the MICT than shown in the following sections, the scope of 
functions may differ. 
 

8.1  MICT System Requirements 
For the installation of the MICT, the following minimum requirements must be fulfilled: 

– x86-compatible computer 

– Display with a resolution of at least 1440 x 900 pixels (WXGA+) 

– USB interface 1.1 or higher 

– Microsoft® Windows 10, Windows 11 
 

8.2  MICT Installation 
   

 

Note the compatibility of the MICT versions 

Older firmware versions of certain MOTORTECH devices are not 
supported by the MICT version provided on the data carrier, or are only 
supported with restrictions. 

When selecting the MICT version to be installed, please refer to the 
compatibility overview on the data carrier supplied with the product. 

     
The software for installing the MICT is on the storage device enclosed with the ITB-DCthrottle. 

To install the MICT, proceed as follows:  

1. Start the installation: 

– Via the menu: 
Start the file Start.exe on the storage device. Start the installation routine of the MICT via 
Software -> Install MICT. 

– Directly from the storage device: 
Start the installation routine of the MICT directly. It is on the storage device in the 
subdirectory Installation and for example named as follows: MICT-2.48.0-setup.exe. 

2. Run the installation. 
Follow the instructions of the installation routine. Note that the license agreement terms must 
be accepted before using the MICT. 

3. Install the USB driver via the menu as well or directly from the storage device. 

– Via the menu: 
Software -> USB Drivers -> Install USB Drivers 

– Directly from the storage device: 
Start the exe file in subdirectory Drivers(e.g. CDM21226_Setup.exe). 

▸ The MICT is set up. You can connect your computer to the throttle via the USB interface. 
 

8 Settings via the MICT 
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8.3  Access Levels in the MICT 
You can open the MICT on your computer via Start -> Programs -> MOTORTECH -> MICT 2.x.x -> 
MICT 2.x.x. 

After opening the MICT, select the access level for which you have clearance. The access level 
controls the options you have at your disposal in the MICT. The password required for access can 
be obtained from your MOTORTECH contact person (refer to Customer Service Information on 
page 78). You can save the password for your access level using the button Save. It then does not 
have to be entered again the next time the MICT is started. 

 

The following access levels are available: 

– Read Only 
On this level, the user can open a configuration and transfer it to the device. However, he 
cannot make changes to the configuration. The user has read-only access to all other 
settings. 

– Customer 
This level enables the configuration of the basic functions required for operation in addition to 
the read-only function. 

– Service 
This level contains all functions for a standard installation. 

– Advanced Service 
This level offers full access to all functions of the MICT and is enabled and accessible for 
specially trained personnel only. 

The following sections describe the options at your disposal with the Advanced Service access 
level. If you have registered for a different level, you cannot execute all functions shown. 
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8.4  Configuration Pages (Overview) 
The configuration pages are divided into the following sections: 

 

Pos. Area 

 Menu bar 

 Toolbar 

 Navigation bar 

 Configuration section 

 Status bar 

  
The functions in the menu bar, navigation bar and the toolbar as well as the configuration section 
will be described in the following. 

The status bar provides you with the following information (from left to right): 

– Status display 
Indicates whether a connection is established with the device: 

– Green: Connection established 

– Red: The connection was interrupted and is being restored 

– Gray: The connection is not established and is not being restored 

– Indication of the interface being used for the connection to the device 

– Indication of the device ID 

– Indication of the access level of the user in the MICT 



8 Settings via the MICT 
 

Rev. 11/2025 49 

– Indication of the operating level for the ITB-DC if access control has been activated and the 
user has logged on with a PIN. 

– Indication of the MICT program version 
 

8.5  Menu Bar and Toolbar 
The following functions are available to you via the symbols on the toolbar and the entries in the 
menu bar: 

Symbol Menu Function 

 

File -> New  Creates a new configuration. 

 

File -> Open Opens an existing configuration. 

 

File -> Save / 
File -> Save As 

Saves the current configuration. 

 File -> Recent Documents The last five configuration files used are offered 
for selection. 

 File -> Close Closes the current configuration. 

 File -> Open trace Opens a runtime data record (trace file). Refer 
to the section Runtime Data on page 65. 

 File -> Open pickup trace Opens a saved recording of pickup signals 
(putrace file), for example from a MOTORTECH 
ignition controller. Pickup signals cannot be 
recorded by the ITB-DC. 

 

File -> Change Access Level Changes the MICT access level for accessing 
the configuration data and functions. 

 

File -> Print Prints the current configuration. 

 

File -> Print To PDF File Prints the configuration to a PDF file. 

 File -> Print Preview Opens a print preview of the configuration. 

 File -> Quit Exits the MICT. 

 

Device -> Connect Connects to the device. 

 

Device -> Disconnect Cuts the connection to the device. 
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Symbol Menu Function 

 

Device -> Download to device Downloads configuration data from the 
computer to the device. This function can only 
be executed in manual mode. 

 

Device-> Upload from device Uploads configuration data from the device to 
the computer. 

 

Device -> Runtime data Opens the window Runtime Data. Refer to the 
section Runtime Data on page 65. 

 

Device -> Log Opens the window Log (Advanced Service 
only). Refer to the section Log on page 72. 

 Device -> Select Mode Opens the window Select operation mode in 
which you can select the operation mode. The 
following modes are possible: Manual Operation 
Mode or Automatic Operation Mode. 

 Device -> Manual Adjustment Opens a window in which you can manually 
adjust the opening angle. 

 Device -> Open Position Completely opens the throttle in manual mode. 

 Device -> Close Position Completely closes the throttle in manual mode. 

 Device -> Position 1 In manual mode, drives to the position 1 defined 
in the configuration by a percentage. 

 Device -> Position 2 In manual operation, drives to the position 2 
defined in the configuration by a percentage. 

 Device -> Reference Run Initiates a reference run in manual mode 
(Service and Advanced Service only). 

 Device -> Temperature 
Extremes 

Opens a window in which the maximum and 
minimum temperature are displayed. These 
values are measured throughout the operating 
time on the board of the ITB-DC. 

 Device -> Error Acknowledge All operational errors are acknowledged. 

 Device -> Trigger Error The process carried out by the stepper motor 
driver (e.g. a reference run), is canceled and the 
stepper motor driver switches into error mode. 

 Device -> Access Control The setup for the access control to the device is 
described in a separate section. Please read the 
section Access Control of Throttle on page 52. 

 Settings -> Language Opens the window Select Language in which 
you can change the interface language of the 
MICT. 

 Settings -> Online update 
settings 

Opens the window Online Update Settings. 
Refer to the section Online Update Settings on 
page 51. 
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Symbol Menu Function 

 Settings-> Database settings Opens a dialogue window in various databases 
can be assigned as source for the MICT. 

 Settings -> Temperature scale Opens the window Select Temperature Scale, in 
which you can change the unit for the 
temperatures shown in the MICT. 

 Settings -> Display by cylinders This function is available for certain 
MOTORTECH ignition controllers and has no 
effect in conjunction with the ITB-DC. 

 Document Has no function with the ITB-DC. 

 Tools -> Coils Opens a database with information on 
MOTORTECH ignition coils. 

 Tools -> Knock Sensor 
Recording 

Opens a tool for analyzing knock sensor 
recordings recorded with MOTORTECH Knock 
Controller. 

 Help -> Help Opens the online help function. 

 Help -> About MICT Opens detailed information on the MICT. 

 
 

8.6  Online Update Settings 
  

 

Perform regular online updates 

MOTORTECH is constantly expanding its databases. Perform regular 
online updates to make optimal use of the opportunities that the ITB-DC 
provides. 

  
The MICT uses data from various databases for the configuration. Such data can be updated with 
automatic online updates. The settings for the update can be entered with the following entry in 
the menu bar: 

Settings -> Online update settings 
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You have the following options: 

– Enable automatic database updates 
Using the check box, you can enable and disable automatic online updates. As the default 
setting, the online update is activated and is executed daily (if an internet connection is 
established) at first start-up of the MICT. 

– Use a proxy to access the web 
Use the checkbox to activate settings for internet access via a proxy server, which you can 
then set up by entering http-Proxy and Port. 

– Show Log 
With this button, you can open a window in which the online updates performed are logged. 

– Update Now 
With this button, you manually start an online update. 

 

8.7  Access Control of Throttle 
If the access control to the throttle is activated, access to the following areas is possible with a 
PIN only: 

– Troubleshooting 

– Position changes (open, closed, position 1 and 2, manual adjustment, reference run) 

– Configuration (transfer of a configuration to the throttle) 

The access control regulates the accesses to the throttle via the MICT. For explanations 
concerning access control of the throttle and the delimitation of the access levels in the MICT, 
refer to section Access Levels in the MICT on page 47. 

The access control functions can be accessed in the menu bar via: 

Device -> Access Control 
 

8.7.1 Enable/Disable Access Control 
   

 

Enable/Disable access control 

As a default setting, the access control is not enabled, and all PINs are set 
to 0000. Once the access control has been enabled, and the PINs were 
changed, these PINs will continue to be used. To re-enabled the access 
control, you will need the PIN for level 3 (Master). It is therefore 
recommended to reset all PINs before disabling. 

If that was not done, or a system must be unlocked for another reason, a 
request key can be issued in the MICT. Refer to the section Resetting all 
PINs on page 53. 

   

To enable or disable the access control, proceed as follows: 

1. Open the input dialog via Device -> Access Control -> Enable or Disable access control. 

2. Enter the PIN for the level Master (Level 3). 

3. Confirm the input with OK. 
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8.7.2 Login/logout 
If the access control is enabled, you are prompted to log in if you want to execute functions that 
are allocated to a specific operating level. In addition, you can log in specifically to an operating 
level via the menu bar. 

To log into a specific operating level, proceed as follows: 

1. Open the input dialog via Device-> Access Control -> Login. 

2. First select the level you wish to log on to. 

3. Enter the PIN for the desired level. 

4. Confirm the input with OK. 

▸ You are now logged into the corresponding level and can execute all functions that are 
allocated to this operating level without having to log in again. 

After completing the log-in, you can log out again as follows: 

Device -> Access Control -> Logout 
 

8.7.3 Changing the PIN 
To change the PIN for a specific operating level, proceed as follows: 

1. Open the input dialog via Device -> Access Control -> Change PIN. 

2. First select the level for which you wish to change the PIN. 

3. Enter the current PIN for the desired level. 

4. Enter the new PIN in the two subsequent fields. 

5. Confirm the input with OK. 

▸ The PIN for this operating level has now been changed. 
 

8.7.4 Resetting all PINs 
To reset all PINs, proceed as follows: 

1. Open the input dialog via Device -> Access Control -> Reset all PINs. 

2. If you are not yet logged into the Master (level 3) level, you will be prompted to log in with the 
relevant PIN. 

3. Confirm the input with OK. 

4. To reset all PINs, you will be prompted again to enter the PIN for the level Master (Level 3). 

5. Confirm the input with OK. 

▸ All PINs are now reset to the value 0000. 

To reset all PINs, you need the PIN for the level Master (level 3). To be able to unlock a system in 
case of emergency that was locked in this way, you have the following option: 

1. In the menu bar, select the entry Device -> Access Control -> Get reset all PINs request key 
to open a window with the same name. 
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2. Send the request key with the serial number to your service contact person at MOTORTECH 
(refer to Customer Service Information on page 78). This key is valid only for the respective 
controller and only for a certain amount of time. 

▸ Your information will be verified, and you will receive an authorization key from your 
contact person. 

3. From the menu bar, select the entry Device -> Access Control -> Set reset all PINs 
authorization key to open a window with this name. 

4. Enter the authorization key received in the input field. 

5. Confirm the input with OK. 

▸ If the input was correct, all PINs are reset to the default value 0000. 
 

8.8  Working with Configurations 
To ensure that the ITB-DC throttle interprets incoming data correctly and converts them to the 
desired control signals, it requires information on connected the master control. This information 
is stored in a configuration file on the stepper motor driver. 

You need the MICT for the following tasks: 

– Creating configuration files 

– Opening configuration files from a storage device 

– Processing configuration files 

– Saving configuration files on a storage device 

– Downloading configuration files to a ITB-DC throttle 

– Uploading configuration files from a ITB-DC throttle 

– Displaying current and saved runtime data  
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8.8.1 Create, Open, Save 

 

Click on the symbol to create a new configuration and select the entry Integrated 
Throttle Bodies -> ITB-DC. 

  

 

Click on the symbol to open a saved configuration. 

  

 

Click on the symbol to save the configuration currently displayed in the MICT to a 
storage device. 

 
 

8.8.2 Upload, Download 

 

Click the symbol to upload the current configuration from the ITB-DC throttle to 
the MICT. If applicable, the MICT first establishes a connection to the throttle 
connected. 

 

Click the symbol to download the configuration in the MICT to the ITB-DC 
throttle. This function can only be executed when the throttle is in manual mode. 
This action overwrites the existing configuration on the device. If applicable, the 
MICT first establishes a connection to the throttle connected. 
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Existing configuration is cleared! 

If you download a configuration to a ITB-DC throttle the previously used 
configuration is deleted and the new settings are immediately 
implemented. 

  
 

8.8.3 Compatibility Information 

 

If you upload a configuration from the ITB-DC throttle to the MICT that does not correspond to the 
status of your MICT, or if you open this type of configuration in the MICT, the following situations 
may occur: 

– No values are present in the configuration for certain MICT functions. The MICT assumes the 
standard values for these functions. 

– The configuration contains function values that are not support by the MICT. 

The following situations can occur if you download a configuration from the MICT to a ITB-DC 
throttle whose firmware does not correspond to the status of your MICT: 

– No values are present in the configuration for certain firmware functions. The firmware 
continues to use the preset values for these functions. 

– The configuration contains function values that are not support by the firmware. 

If you download a configuration to the throttle and are notified of functions that are not supported 
by the MICT, you should check the throttle settings. Re-upload the configuration from the throttle 
to the MICT. You can then see which settings are not transmitted to the MICT. 

Perform a firmware update, if necessary and/or update your MICT so that you can use all the 
functions of the ITB-DC throttle without restriction. 
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8.9  Configuration 
The window opens after you select the device type for a new configuration or an existing 
configuration or have uploaded one from the device. You can make changes to the configuration 
by selecting an entry from the navigation bar. The corresponding configuration data are then 
displayed in the configuration section and can be processed. The following sections will describe 
the settings and adjustments you can implement in the different areas. 

  

 

Indication of invalid entries 

An invalid selection or invalid input values are highlighted by pulsating 
warning signs on the configuration pages of the MICT. Additional 
information is provided in the status bar. 

Example: 
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8.9.1 External Device 

   

To change the device type, approval for the access level Advanced Service is required. 

External Device 
Select the device type you wish to configure and control from the drop-down list. 

When the device type has been changed and the modified configuration has been downloaded to 
the device, the LED on the device flashes orange. This indicates that a reference run in required. 

– Throttle 
Select this option to select from the following drop-down list the throttle body with integrated 
stepper motor (ITB-DC) that corresponds to your application. 
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8.9.2 Inputs/Outputs – Control Setup 

   

The settings on the configuration page depend on the inputs and outputs used by your master 
control. In this case, refer to all information given in the relevant documentations of the control 
units. To make changes, approval for the access level Advanced Service is required. 

Selection 
– Input 

Select the input that is to be used for position setting by the master control connected. The 
following options are possible: 

– Analog Current 
Position setting is achieved via the analog current signal.  

– Fieldbus 
Position setting is achieved via a fieldbus. This requires corresponding configuration of 
the communication with the desired fieldbus (see Miscellaneous – Communication on 
page 62). 

– Output 
Shows the analog output used by the master control connected. For the ITB-DC, only an 
analog current output is available. If the connected controller only has a voltage input, refer to 
the example at the end of this section. 
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Input/Output 
– Input Current 

For the analog input, enter the values for the open and closed position. Note the value range 
for the current input from 0 mA to 20 mA. 

–  
Click this button to apply the settings of the analog current input to the analog current output. 

– Output Current 
Enter the current values that should correspond to the open and closed position. Here, the 
same value ranges are applicable as with the analog inputs. 

– Cable Break Detection 
If the throttle is controlled via the analog current input, cable break detection can be 
activated. 

– Failure Threshold 
Enter a value for the failure threshold. If the input current falls below this failure threshold, 
the throttle enters the error mode and the binary error output is switched. The throttle 
then moves to the error position defined in the MICT if it is activated. 

– Fieldbus Monitoring 
If the throttle is controlled via fieldbus, the fieldbus monitoring can be activated. 

– Target Position Timeout 
Enter the time that the controller tolerates without information on the target position via 
the fieldbus before it enters the error mode. If this value is exceeded, the binary error 
output is switched. The throttle then moves to the error position defined in the MICT if it is 
activated. 

Binary Output 
The binary output is active if an error has occurred and the throttle is in automatic mode. 

– Error 
Set the error output as a normally closed or normally open. 

  

 

Setting the analog current input 

Based on the values used by your master control, you can define the 
values of the open and the closed position for the analog current input in 
the MICT. The value applied on the input will then be converted to the 
relevant opening angle of the throttle proportional to the values entered. 

Example: 

Your master control works with a current input of 4 mA to 20 mA. In the 
MICT, you configure 4 mA to refer to the closed position and 20 mA to the 
open position. If the current on the input is now 16 mA, the opening is 
75 %. 
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Example: Use of a voltage input 

The SC100 speed control has a voltage input. The following steps are 
required to connect the position feedback signal of the ITB-DC (current 
output) to the feedback input of the SC100 (voltage input): 

1. Connect the 270 Ω resistor supplied with the harness in parallel to the 
signal lines between the ACT fbd and Fdb GND clamps on the SC100.  

2. Define the values under Analog sensors in WinScope; e.g:  
Fdb 0 pos: 0.70 V 
Fdb 100 pos: 4.48 V. 

3. Adjust the values of the analog current output on the configuration 
page Inputs/Outputs – Control Setup in the MICT: e.g. 
Close: 2.6 mA (0.70 V/270 Ω = 2.6 mA) 
Open: 16.6 mA (4.48 V/270 Ω = 16.6 mA) 

  
 

8.9.3 Positions – Values 
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Position 1/Position 2 
You can define two configurable positions using these two input fields. This requires approval for 
the access level Service or Advanced Service. Enter the desired opening angle of the gas supply 
for the throttle as a percentage value (100 % corresponds to open, 0 % corresponds to closed). 
The openings specified here can be set in manual mode via the MICT and in automatic mode via 
fieldbus . 

For further information, refer to the section Configurable Opening Angles (Position 1 and 2). 

Action on Error 
For the Target Position, enter the desired degree of opening that the throttle should move to in the 
event of an error, if this is still possible. For example, in the event of a step loss or overcurrent 
error, the stepper motor can generally no longer fulfill this request. The target position is also 
approached if the failure threshold for cable break detection is undercut or the position target 
timeout is exceeded when operating with fieldbus. Refer to the section Monitoring the Control 
System on page 43. 
 

8.9.4 Miscellaneous – Communication 

   

CAN 
Via the field CAN, deactivate or activate the CAN interface of the device.  

– ALL-IN-ONE (J1939)/J1939/J1939 Harness Coding/CANopen 
Select the desired protocol, depending on whether you want to set the communication for the 
ALL-IN-ONE or for another master control.  
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– Source Address/CANopen Node ID 
In the protocol ALL-IN-ONE (J1939) the source address can be assigned between 0 and 253. 
In the CANopen protocol, a CANopen node ID from 1 to 127 can be assigned. Note that IDs 
cannot be assigned more than once. 

– Bitrate 
Select the desired data transfer rate from the list. In the protocol ALL-IN-ONE (J1939), 
250 kbit/s and 500 kbit/s are available for selection. In the CANopen protocol, a bit rate from 
50 kbit/s to 1 Mbit/s can be set. For both protocols, we suggest the use of a baud rate of 
250 kbit/s. 

– Instance Number 
If you are using several throttles in the field bus, you can assign an instance number here to 
make it easier to distinguish between the configurations and the communication parameters 
defined in them. 

RS485  
Not available for the ITB-DC. 

Additional CAN Parameters 
– Transmission Repetition Rate 

Set the repetition rate for the transmission of the TXPGN in the fieldbus. 

– J1939 PGN 

– Receive/Transmit 
Set the parameters for communication in the fieldbus. 

– Harness Coding 
If you use coded harnesses, you can use one configuration for up to four devices. Depending 
on the instance, the specified communication parameters are then used. The instance is 
defined via harness coding. Refer to the section Wiring Binary Inputs on page 37. 

  

 

Setting the transfer rate 

Please note that all devices connected with a bus must be set to the same 
transfer rate. 

   

 

Information on protocols 

Please contact your MOTORTECH contact person if you require more 
information on the CANopen®, J1939 and Modbus protocols. 
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8.9.5 Miscellaneous – Information 
This configuration page can be viewed by all users, but changes can only be made with 
authorization for the Service access level. 

 

Site and Module 
In this section, enter information on the system and the module for which the configuration will be 
used. 

Service Contact 
In this section, individual contact data can be saved that can be called up and displayed via MICT. 
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8.10  Runtime Data 

 

Click on the symbol to open the window Runtime Data. The following sections 
will give you an overview of the data you can view on the individual tabs. 

You can print and record the runtime data. For this purpose, the following functions are at your 
disposal in the toolbar in the window: 

Symbol Function 

 

Prints the runtime data. 

 

Prints the runtime data to a PDF file. 

 

Opens the print preview. 

 

Starts the runtime data trace. 

 

Stops the runtime data trace. 

   

 

Save runtime data locally 

You should always save runtime data on the local computer and not on a 
network drive or external storage device. Trace files can only be moved 
freely once the recording is stopped. 
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8.10.1 Runtime Data – Overview 

    

You can find the following information in the window: 

Configured 
The status display shows whether there is a valid configuration on the throttle: 

– green: The throttle has a valid configuration. 

– red: The throttle has no or an invalid configuration. An existing configuration can for example 
become invalid during a firmware update. The throttle is not ready for operation again until a 
valid configuration is downloaded to the device. 

Reference Run 
The status display provides information on the reference run: 

– green: The reference run was completed successfully. 

– yellow: The reference run is being carried out. 

– red: Errors occurred during the reference run. The reference point was not found. 
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Manual/Auto 
The status display indicates the operation mode selected: 

– green: The operation mode is set. 

– yellow: A command is carried out in the operation mode selected. In automatic operation 
mode, the status display will only turn yellow if position 1 or 2 is approached. 

– red: An error occurred in the operation mode selected. 

Stepper Motor 
The status display indicates the condition of the stepper motor: 

– green: The stepper motor is ready. 

– yellow: The stepper motor is active. 

– red: An error occurred. 

Undervoltage Warning 
The status display signals a drop in the supply voltage below 15 V. Please also observe the voltage 
drop on the harness. 

– green: The supply voltage is above 15 V. 

– red: The supply voltage is below 15 V. 

Warning/Error 
A red status display indicates that a warning or an error has occurred. The display will go out if the 
warning or the error is acknowledged via the MICT (Device -> Error Acknowledge). Refer to the 
section Runtime Data – Message Log on page 68. 

Opening 
– Target 

The value is assigned to the throttle in automatic mode by the master control or, in manual 
mode, by the MICT.  

– Actual 
The displayed value represents the opening of the throttle as a percentage. 
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8.10.2 Runtime Data – Message Log 

  

In the view Message Log, information, warnings and errors are listed. 

The following information is provided: 

– Operating Hours 
Operating hours counter reading at the time of message 

– Time 
Time and date cannot be shown for ITB-DC throttle. 

– Category 
Message type (information, warning, error) 

– Message 
Message text; you can find more information on the message text in the following sections. 

You have the following options: 

– Automatic scrolling 
If this box is checked, the system automatically displays the last list entry until a new event 
occurs. 
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8.10.2.1 Information 
Information 

Configuration changed. 

Device (firmware version) started at a supply voltage of value.  

Device switched off. 

Message log cleared. 

NVRAM formatted. 

One or more messages are lost due to exhausted memory pool or message 
queue overrun. 

Shutdown timestamps cleared. 

Step control heavy load. 

Step loss error self acknowledged. 

  
For all information, the status of the ITB-DC when the information occurred is indicated. Additional 
parameters are provided if necessary. 
 

8.10.2.2 Warnings 
Warning 

Cpu usage. 

General warning.  

Reset life time.  

Use backup life time.  

  
For all warnings, the status of the ITB-DC when the warning occurred is indicated. Additional 
parameters are provided if necessary. 
 

8.10.2.3 Errors 
Errors 

CAN handler message queue full. 

Error triggered by command.  

Coprocessor handler message queue full. 

General error. 

Input handler message queue full. 

Interframe step loss. 

Low Power  

Output handler message queue full.  

Over current. 

Over temperature.  
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Errors 

Stop step loss. 

Timeout. 

Background task message queue full. 

Cable break detected on analog current input. 

Target position timeout detected on fieldbus. 

  
For each error message, the status of the ITB-DC at the time the error occurred is provided. 
Additional parameters are provided if necessary.  
 

8.10.3 Runtime Data – Diagnostics 

   

In this screen, you can find the following information: 

Supply Voltage 
Current supply voltage of the device. 

Current Temp 
Current temperature of board. 

Max Temp 
Maximum board temperature reached since the last time the device was switched on. 
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Min Temp 
Minimum board temperature reached since the last time the device was switched on. 

Max. Step Loss 
Internal diagnosis parameters associated with the control of the stepper motor. The maximum 
step losses that have occurred since the last switch-on are displayed. If the step losses are too 
high, this will cause an error message. 
 

8.10.4 Runtime Data – Information 

   

In this view, you can find an overview of the device and version data. You also have the option of 
printing this data in the same way as all current runtime data or sending it as a PDF to 
MOTORTECH Service Department by e-mail in the event of problems. For fast support, we will 
then immediately have all required information. 
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8.11  Log 

 

Click on the symbol to open the window Log. This window is only available to 
users with authorizations starting at the access level Advanced Service. 

  

The window Log serves to support error diagnostics by MOTORTECH.  

– Automatic scrolling 
If the function is active, the view panel focuses on the latest message. 

– Log level 
The selection of the log level is specified by MOTORTECH if needed. 

– Write log to file 
This checkbox activates or deactivates, respectively, the saving of the logged data in a 
selected file. If the function is disabled, the logged data are merely shown on the display. 

– Select file 
With this button, you can select a file to which you want to save the logged data. 

If you are prompted to create a log file in the case of a service request, proceed as follows: 

1. Open the window Log via the toolbar or the menu bar. 

2. Select a path with the Select file button and enter the file name for the log file. 

▸ If the file does not yet exist, it is automatically created with the extension .log. 

3. Activate the checkbox Write log to file. 

4. Select the level specified by MOTORTECH from the list Log level. 

5. Leave the window open. 

▸ The log messages are logged both in the window and in the selected file. 
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9.1  Start-up 
Before you start up the throttle body, take note of the following: 

– The throttle body has to be properly installed. 

– The tightness of the system must have been checked. 

– The throttle body and the seals have to be without any damage. 

– Make sure that there are no foreign bodies in the piping. 

– Ensure that the wiring of the harness is implemented correctly. 

– Ensure that no gas is present in the inlet and exhaust systems before you start the engine. 

– Ensure that the gas valve is closed. 

– The screws or threaded rods have to be tightened firmly. 
 

9.2  Shutdown 
When shut down the device, first switch off the power supply before disconnecting the plugs. 
Before dismounting the device, the gas supply must be switched off and the pipe must be free of 
gas. 
 

9.3  Firmware Update 
Using the MOTORTECH Flash Tool, you can perform a firmware update for the throttle. The 
provided storage device comprises this program. 

Install MOTORTECH Flash Tool 
Install the MOTORTECH Flash Tool as follows: 

1. Start the installation: 

– Via the menu: 
Start the file Start.exe on the storage device. Start the installation routine for the 
MOTORTECH Flash Tool via Software -> MOTORTECH Flash Tool -> Install MOTORTECH 
Flash Tool. 

– Directly from the storage device: 
Start the installation routine of the MOTORTECH Flash Tool directly. It is on the storage 
device in the subdirectory Installation and for example named as follows: MOTORTECH-
Flash-Tool-0.23.00000-setup.exe. 

2. Install the program. 
Follow the instructions of the installation routine. Note that the license agreement terms must 
be accepted before using the MOTORTECH Flash Tool. 

3. If the USB driver is not yet installed, also install it via the menu or directly from the storage 
device. 

– Via the menu: 
Software -> USB Drivers -> Install USB Drivers 

– Directly from the storage device: 
Start the exe file in subdirectory Drivers 
(e.g. CDM21226_Setup.exe). 

▸ The MOTORTECH Flash Tool is set up. You can now connect your PC to the throttle via 
the USB interface. 

9 Operation 
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Menu Bar and Toolbar 
After launching the MOTORTECH Flash Tool, the following functions are available to you via the 
icons on the toolbar and the entries in the menu bar: 

Symbol Menu Function 

 

File -> Open Opens a firmware file. 

  File -> Quit Exits the program. 

  View -> Extended file 
information view 

Fades in / out additional information of the 
firmware file. 

  View -> Extended connection 
settings 

Fades in/out additional information and settings 
of the connection to the device. 

 

View -> Reload file Reloads the file information of the selected 
firmware file. 

 

Device -> Search devices Restarts the search for connected devices. 

 

Device -> Flash device Starts the update process or downgrade 
process. 

  Settings -> Language Opens the window Select Language in which 
you can change the interface language of the 
program. 

  Help -> Help Opens the online help function. 

  Help -> About MOTORTECH 
Flash Tool  

Opens detailed information on the program. 

  

Start Firmware Update 
  

 

Access control for firmware update 

If you have activated the access control for the device, you need the PIN 
for the level Master for the firmware update. For more information read 
the section Access Control of Throttle on page 52. 
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Backup the existing configuration 

Your device's configuration may be lost if the firmware update is not 
performed properly. Always backup the existing configuration via the 
MICT prior to performing an update. For more information read the 
section Working with Configurations on page 54. 

  
To start a firmware update, proceed as follows: 

1. If an MICT is connected with the throttle, disconnect this connection. 

2. Start the MOTORTECH Flash Tool viaStart -> Programs -> MOTORTECH -> MOTORTECH 
Flash Tool -> x.x.x (e.g. 0.23.00000) -> MOTORTECH Flash Tool. 

▸ The MOTORTECH Flash Tool will now start. 

▸ The software automatically checks all ports for connected devices. 

3. In the Status section under Device, check if your device has been recognized properly. 

▸ If the MOTORTECH Flash Tool does not recognize a device that is connected to your 
computer via the USB interface, you can usually still carry out a firmware update. To do 
so, observe the instructions in the information windows of the MOTORTECH Flash Tool 
for the following steps. 

4. In the area File, select the desired update file via the folder icon in the field Path. 

5. By reading the displayed file information, ensure that the update file is correct for your device. 

6. Start the update process using the Flash button or using the menu or toolbar. 

▸ The throttle will be restarted automatically. 

▸ Now, a window opens informing you about the firmware version currently used on your 
throttle and also about the relevant update version. 

7. Confirm with Yes to proceed with the update process. 

▸ Now the update will start. 

▸ If the firmware update was successful, you will see a relevant message. 

▸ Now, the throttle will initiate a reference run. 

8. After a successful firmware update, check all configuration data. 

  

 

Downgrade process 

The process for a downgrade is largely the same as the update process. 
You will only be informed that a new firmware has been installed on the 
device. 
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Help with connection problems 

If a correctly connected device is not found during the automatic search, 
this can, for example, be because too many communication interfaces are 
assigned and must be checked. In this case, an interface from the drop-
down list Port in the area Connection can be selected and thus specified.  

If the desired port is not yet displayed in the list or if the problem should 
continue, an adjustment of the time-outs for the connection helps. The 
time-out settings are displayed in the main view by the following entry in 
the menu bar: View -> Extended connection settings 

Enter the following settings: 

– Update Request Timeout 
Adjustment range: 1,000 ms to 10,000 ms, standard value: 3,000 ms. 
An extension of the time-out can be an advantage, especially with 
connection problems that occur because the computer has many 
assigned ports. 

– Start Timeout 
Adjustment range: 1,000 ms to 10,000 ms, standard value: 3,000 ms. 
A time-out change can be an advantage, especially with connection 
problems that occur because the communication between the 
computer and the device has been interrupted. 
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10.1  Possible Faults 
Fault Possible cause Solution 

The supply voltage 
has dropped 
below 8 V. 

The power supply is dimensioned 
too small. 

Provide a power supply in 
accordance with the technical 
specifications. 

The starter battery is worn out. Do not operate the throttle body 
from the starter battery. 

The wiring for the power supply is 
routed defective or incorrectly. 
Please also observe the voltage drop 
on the harness. 

Check the wiring and make sure that 
the supply voltage is available. 

The predefined 
steps are not 
carried out by the 
stepper motor. 

The throttle body is stuck (e.g. due 
to pollution). 

Clean the throttle body. 

The stepper motor or the integrated 
stepper motor driver is defective. 

Please contact your MOTORTECH 
contact person for repair. 

 

The temperature 
of the board has 
been exceeded. 

The ambient temperature is too high. Ensure sufficient ventilation. 

Air circulation around the device is 
insufficient. 

Ensure sufficient air circulation. 

The cooling body is dirty. Clean the cooling body. 

The reference run 
failed. 

The throttle body is stuck (e.g. due 
to pollution). 

Clean the throttle body. 

The stepper motor or the integrated 
stepper motor driver is defective. 

Please contact your MOTORTECH 
contact person for repair. 

 

The current to the 
stepper motor is 
too high. 

The stepper motor is defective. Please contact your MOTORTECH 
contact person for repair.  

The stepper motor driver is 
defective. 

Please contact your MOTORTECH 
contact person for repair. 

The throttle body 
does not move. 

The connection between the throttle 
body and the master control is 
faulty. 

Check the wiring. 

The stepper motor or the integrated 
stepper motor driver is defective. 

Please contact your MOTORTECH 
contact person for repair. 

 
 

10 Errors 
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10.2  Acknowledging Faults 
In manual mode, you have the following options for acknowledging operational errors: 

– Via Error acknowledge in the MICT 

In automatic mode, you have the following options for acknowledging operational errors: 

– The master control sends a signal to the binary reset input 

– the higher-level control system sends a corresponding signal via the fieldbus 

– Via Error acknowledge in the MICT 

Critical errors can only be acknowledged by switching the device off and on. 

  

 

Error confirmation in automatic operation 

If the ITB-DC is in automatic mode and an error immediately reoccurs 
after the acknowledgment of this error via the MICT, switch over into the 
manual mode before re-acknowledging the error again. After you have 
acknowledged the error, you can correct a defective configuration and 
transfer it to the device via download. 

 
 

10.3  Customer Service Information 
You can reach us during our business hours by: 

Phone: +49 5141 93 99 0 

Email: service@motortech.de (technical support) 
sales@motortech.de (all other matters) 

  
 

10.4  Returning Equipment for Repair/Inspection 
To return the device for repair and inspection, first consult your MOTORTECH contact person (see 
Customer Service Information on page 78). From him you will receive all the information you need 
to process your order quickly and smoothly. For return shipment, also observe the instructions in 
the section Instructions for Packaging the Equipment on page 78. 
 

10.5  Instructions for Packaging the Equipment 
For return shipment, equipment should be packaged as follows: 

– Use packaging material that does not damage the equipment surfaces. 

– Wrap the equipment with sturdy materials and stabilize it inside the packaging. 

– Use sturdy adhesive film to seal the packaging. 
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11.1  Maintenance Instructions 
  

 

Explosion hazard! 

If the system is not entirely tight and sealed, the combustible gas mixture 
may escape and result in an explosion hazard. 

If the device is demounted by the customer for installation or 
maintenance purposes, the customer is responsible for restoring the 
system's leak tightness. 

  

Observe the following maintenance instructions: 

– Do not use caustic liquids for cleaning the device. 

– A visual inspection must be carried out every time the engine is serviced within the normal 
service intervals of your system. 

– Dirty seals can lead to leakage of the throttle body. When replacing seals, only use clean seals 
from MOTORTECH. 

– For repair, the device must be returned to MOTORTECH (see Returning Equipment for 
Repair/Inspection on page 78). If needed, a replacement or exchange device can be provided. 
For this purpose, contact your MOTORTECH contact person (see Customer Service 
Information on page 78). 

 

11.2  Spare Parts and Accessories 
For spare parts and accessories, please refer to our current Product Guide, which is available for 
you to download on the internet at www.motortech.de. 

 

11 Maintenance 
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